Community Health Group of SD (Z1700) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 20, 2024 - 15:41 EST
Update
Community Health Group of SD (Z1700) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 13, 2024 - 10:02 EST
Update
Community Health Group of SD (Z1700) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 07, 2024 - 14:08 EST
Update
Community Health Group of SD (Z1700) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 01, 2024 - 10:25 EDT
Identified
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected: