Real-Time Eligibility Payer Outages
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 21, 2025 - 11:17 EST
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 16, 2025 - 15:28 EST
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 13, 2025 - 11:41 EST
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 07, 2025 - 10:32 EST
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 06, 2025 - 08:12 EST
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 26, 2024 - 08:57 EST
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 19, 2024 - 10:42 EST
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 16, 2024 - 11:02 EST
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 09, 2024 - 10:57 EST
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 04, 2024 - 09:31 EST
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 25, 2024 - 15:31 EST
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 20, 2024 - 11:11 EST
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 13, 2024 - 09:34 EST
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 07, 2024 - 13:50 EST
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 01, 2024 - 10:12 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 22, 2024 - 09:11 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 07, 2024 - 09:48 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 03, 2024 - 09:12 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Sep 24, 2024 - 09:18 EDT
Update
AmeriBen Solutions Inc (75137) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Sep 16, 2024 - 08:51 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Sep 09, 2024 - 09:05 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Aug 28, 2024 - 11:51 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Aug 14, 2024 - 09:21 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jul 31, 2024 - 08:09 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jul 19, 2024 - 13:33 EDT
Update
AmeriBen Solutions Inc (75137) & Indiana University Health Plan (Medicare) (95444) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jul 10, 2024 - 09:05 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted Jun 28, 2024 - 09:47 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212) - Fully responding (RESOLVED)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316) - Fully responding (RESOLVED)
Medical Associates Health Plans/Health Choices (Z1269) - Fully responding (RESOLVED)
Posted Jun 25, 2024 - 08:14 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted Jun 17, 2024 - 10:11 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212) - Fully responding (RESOLVED)
Indiana University Health Plan (Medicare) (95444) - Fully responding (RESOLVED)
Leon Medical Center Health Plan (37316) - Fully responding (RESOLVED)
Medical Associates Health Plans/Health Choices (Z1269) - Fully responding (RESOLVED)
Posted Jun 13, 2024 - 10:46 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted May 29, 2024 - 10:50 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted May 22, 2024 - 08:58 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted May 15, 2024 - 09:27 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted May 09, 2024 - 08:50 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted Apr 30, 2024 - 11:42 EDT
Identified
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

AmeriBen Solutions Inc (75137)
Indiana University Health Plan (26212)
Indiana University Health Plan (Medicare) (95444)
Leon Medical Center Health Plan (37316)
Medical Associates Health Plans/Health Choices (Z1269)
Posted Apr 25, 2024 - 13:21 EDT