BCBS New Jersey (22099) & Horizon NJ Health (22326) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 07, 2024 - 14:12 EST
Update
BCBS New Jersey (22099) & Horizon NJ Health (22326) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 01, 2024 - 10:27 EDT
Identified
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:
BCBS New Jersey (22099) - Fully responding (RESOLVED) Horizon NJ Health (22326) - Fully responding (RESOLVED)