Real-Time Eligibility Payer Outages

Update

Paramount Health (SX158) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 03, 2025 - 08:15 EDT

Update

Paramount Health (SX158) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 02, 2025 - 13:11 EDT

Update

Paramount Health (SX158) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 31, 2025 - 08:29 EDT

Update

Paramount Health (SX158) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 28, 2025 - 11:01 EDT

Update

Paramount Health (SX158) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 26, 2025 - 11:24 EDT

Update

Blue Cross of Idaho (ZBID0), Medigold Health Plans (95655) & Paramount Health (SX158) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 20, 2025 - 12:43 EDT

Update

Blue Cross of Idaho (ZBID0), Medigold Health Plans (95655) & Paramount Health (SX158) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 14, 2025 - 10:34 EDT

Identified

Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

Blue Cross of Idaho (ZBID0) - Fully responding (RESOLVED)
Medigold Health Plans (95655) - Fully responding (RESOLVED)
Paramount Health (SX158)
Posted Mar 12, 2025 - 09:56 EDT