Real-Time Eligibility Payer Outage

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 08:34 EDT

Update

Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Sentara Health Management (54154)
Posted Mar 20, 2025 - 12:42 EDT

Identified

Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Sentara Health Management (54154)
Posted Mar 17, 2025 - 10:47 EDT