BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 03, 2025 - 08:17 EDT
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 02, 2025 - 13:08 EDT
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 31, 2025 - 08:35 EDT
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 28, 2025 - 10:50 EDT
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 26, 2025 - 11:44 EDT
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 20, 2025 - 12:49 EDT
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 14, 2025 - 08:09 EDT
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 05, 2025 - 11:01 EST
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 28, 2025 - 09:04 EST
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 25, 2025 - 08:22 EST
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 24, 2025 - 09:13 EST
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 18, 2025 - 11:15 EST
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 10, 2025 - 10:35 EST
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 03, 2025 - 13:24 EST
Update
BCBS Puerto Rico (Z0065) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 29, 2025 - 08:02 EST
Identified
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected: