Real-Time Eligibility Payer Outages
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 09:24 EST
Identified
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

Harvard Pilgrim Health Care (04271) - Fully responding (RESOLVED)
Tufts Health Plans (04298) - Fully responding (RESOLVED)
Posted Nov 07, 2024 - 12:10 EST