Real-Time Eligibility Payer Outages

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 15 hours ago. Apr 07, 2025 - 08:44 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 4 days ago. Apr 04, 2025 - 08:03 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 5 days ago. Apr 03, 2025 - 08:19 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 5 days ago. Apr 02, 2025 - 13:06 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 8 days ago. Mar 31, 2025 - 08:43 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 11 days ago. Mar 28, 2025 - 10:48 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 12 days ago. Mar 26, 2025 - 11:51 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 18 days ago. Mar 20, 2025 - 12:51 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 25 days ago. Mar 14, 2025 - 08:03 EDT

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 month ago. Mar 05, 2025 - 10:58 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 month ago. Feb 28, 2025 - 09:00 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 month ago. Feb 25, 2025 - 08:24 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 month ago. Feb 24, 2025 - 09:12 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 2 months ago. Feb 18, 2025 - 11:10 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 2 months ago. Feb 10, 2025 - 10:26 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 2 months ago. Feb 03, 2025 - 13:20 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 2 months ago. Jan 29, 2025 - 07:59 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 3 months ago. Jan 21, 2025 - 11:09 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 3 months ago. Jan 16, 2025 - 14:24 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 3 months ago. Jan 13, 2025 - 11:33 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 3 months ago. Jan 07, 2025 - 10:28 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 3 months ago. Jan 06, 2025 - 07:48 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 3 months ago. Dec 26, 2024 - 08:37 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 4 months ago. Dec 23, 2024 - 09:52 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 4 months ago. Dec 19, 2024 - 10:40 EST

Update

Administrative Services Inc (59141) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 4 months ago. Dec 16, 2024 - 10:59 EST

Update

Administrative Services Inc (59141) and BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 4 months ago. Dec 09, 2024 - 10:29 EST

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 4 months ago. Dec 04, 2024 - 09:26 EST

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 4 months ago. Nov 25, 2024 - 15:25 EST

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 5 months ago. Nov 20, 2024 - 11:13 EST

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 5 months ago. Nov 13, 2024 - 09:50 EST

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 5 months ago. Nov 07, 2024 - 13:59 EST

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 5 months ago. Nov 01, 2024 - 10:15 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 6 months ago. Oct 22, 2024 - 09:18 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 6 months ago. Oct 07, 2024 - 09:56 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 6 months ago. Oct 03, 2024 - 09:19 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 7 months ago. Sep 24, 2024 - 09:21 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 7 months ago. Sep 16, 2024 - 08:54 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 7 months ago. Sep 09, 2024 - 09:13 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 7 months ago. Aug 28, 2024 - 11:54 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a
Posted 8 months ago. Aug 14, 2024 - 09:33 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 8 months ago. Jul 31, 2024 - 08:21 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 9 months ago. Jul 19, 2024 - 13:49 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 9 months ago. Jul 10, 2024 - 09:31 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 9 months ago. Jun 28, 2024 - 09:53 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 10 months ago. Jun 25, 2024 - 07:47 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 10 months ago. Jun 13, 2024 - 10:54 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 10 months ago. May 29, 2024 - 10:42 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 11 months ago. May 15, 2024 - 09:31 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 11 months ago. May 09, 2024 - 07:57 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 11 months ago. Apr 29, 2024 - 09:34 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 23, 2024 - 10:43 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 17, 2024 - 11:30 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 16, 2024 - 10:23 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 15, 2024 - 09:54 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 12, 2024 - 09:13 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 11, 2024 - 11:26 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 10, 2024 - 10:27 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 09, 2024 - 10:56 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 08, 2024 - 14:09 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Apr 04, 2024 - 11:09 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Mar 21, 2024 - 10:53 EDT

Update

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663), Administrative Services Inc (59141) and
BCBS Puerto Rico (Z0065) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted 1 year ago. Mar 19, 2024 - 09:02 EDT

Update

Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663)
Administrative Services Inc (59141)
BCBS Puerto Rico (Z0065)
BCBS North Carolina (SB810)
Posted 1 year ago. Mar 13, 2024 - 10:39 EDT

Update

Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663)
Administrative Services Inc (59141)
BCBS Puerto Rico (Z0065)
BCBS North Carolina (SB810)
Posted 1 year ago. Mar 11, 2024 - 08:10 EDT

Identified

Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

American Family Life Assurance Co AFLAC-Medicare Supplemental (10663)
Administrative Services Inc (59141)
BCBS Puerto Rico (Z0065)
BCBS North Carolina (SB810) - Fully responding (RESOLVED)
Posted 1 year ago. Mar 07, 2024 - 09:53 EST