AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 21, 2025 - 11:17 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 16, 2025 - 15:27 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 13, 2025 - 11:41 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 07, 2025 - 10:31 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jan 06, 2025 - 08:11 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 26, 2024 - 08:56 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 19, 2024 - 10:45 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 16, 2024 - 11:13 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 09, 2024 - 11:01 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Dec 04, 2024 - 09:41 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 25, 2024 - 15:32 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 20, 2024 - 11:11 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 13, 2024 - 09:33 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 07, 2024 - 13:49 EST
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 01, 2024 - 10:11 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 22, 2024 - 09:10 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 07, 2024 - 09:48 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 03, 2024 - 09:12 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Sep 24, 2024 - 09:18 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Sep 16, 2024 - 08:49 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Sep 09, 2024 - 09:05 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Aug 28, 2024 - 11:51 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Aug 14, 2024 - 09:20 EDT
Update
AlohaCare Medicare and Medicaid (Z1375) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jul 31, 2024 - 08:07 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted Jul 19, 2024 - 13:32 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted Jul 10, 2024 - 09:00 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted Jun 28, 2024 - 09:47 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted Jun 25, 2024 - 08:15 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted Jun 17, 2024 - 10:12 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted Jun 13, 2024 - 10:46 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted May 29, 2024 - 10:49 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted May 22, 2024 - 08:52 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted May 15, 2024 - 09:23 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted May 09, 2024 - 08:50 EDT
Update
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:
AlohaCare Medicare and Medicaid (Z1375)
Posted Apr 30, 2024 - 11:42 EDT
Identified
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected: