Real-Time Eligibility Payer Outages
Update
Allegiance Benefit Plan Management Inc (81040) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 20, 2024 - 11:14 EST
Update
Allegiance Benefit Plan Management Inc (81040) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 13, 2024 - 10:01 EST
Update
Allegiance Benefit Plan Management Inc (81040) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 07, 2024 - 14:08 EST
Update
Allegiance Benefit Plan Management Inc (81040) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 01, 2024 - 10:24 EDT
Update
Allegiance Benefit Plan Management Inc (81040) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 22, 2024 - 09:25 EDT
Update
Allegiance Benefit Plan Management Inc (81040) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 07, 2024 - 13:55 EDT
Update
Allegiance Benefit Plan Management Inc (81040) & Group Health Insurance (GHI) of NY (13551) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Oct 07, 2024 - 09:25 EDT
Update
Allegiance Benefit Plan Management Inc (81040) & Group Health Insurance (GHI) of NY (13551) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Sep 24, 2024 - 09:40 EDT
Identified
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:

Allegiance Benefit Plan Management Inc (81040)
Group Health Insurance (GHI) of NY (13551) - Fully responding (RESOLVED)
Posted Sep 17, 2024 - 09:53 EDT