Real-Time Eligibility Payer Outage

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 11:27 EDT

Update

Maryland Public Behavioral Health System (BHOMD) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 20, 2025 - 12:43 EDT

Update

Maryland Public Behavioral Health System (BHOMD) continue to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 14, 2025 - 10:28 EDT

Identified

Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Maryland Public Behavioral Health System (BHOMD)
Posted Mar 13, 2025 - 10:06 EDT