Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 03, 2025 - 08:15 EDT
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 02, 2025 - 13:11 EDT
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 31, 2025 - 08:30 EDT
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 28, 2025 - 11:00 EDT
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 26, 2025 - 11:35 EDT
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 20, 2025 - 12:45 EDT
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 14, 2025 - 08:26 EDT
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 05, 2025 - 11:36 EST
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 28, 2025 - 09:10 EST
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 25, 2025 - 08:20 EST
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 24, 2025 - 09:49 EST
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 18, 2025 - 11:25 EST
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 10, 2025 - 10:58 EST
Update
Freedom Health Plan (41212) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Feb 03, 2025 - 13:43 EST
Identified
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:
Freedom Health Plan (41212) Sanford Health Plan (91184) - Fully responding (RESOLVED)