Real-Time Eligibility Payer Outage

Update

Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Humana (and subsidiaries) claims (61101)
All BCBS Payers
Centene Health Plans (68069)
Posted Apr 03, 2025 - 08:20 EDT

Update

Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Humana (and subsidiaries) claims (61101)
All BCBS Payers
Centene Health Plans (68069)
Posted Apr 02, 2025 - 11:14 EDT

Update

Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Humana (and subsidiaries) claims (61101)-RESOLVED
All BCBS Payers-INTERMITTENT
Centene Health Plans (68069)- INTERMITTENT
Posted Apr 02, 2025 - 07:54 EDT

Identified

Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Humana (and subsidiaries) claims (61101)
All BCBS Payers
Centene Health Plans (68069)
Posted Apr 01, 2025 - 10:41 EDT