AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Jan 21, 2025 - 11:13 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Jan 16, 2025 - 15:27 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Jan 13, 2025 - 11:40 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Jan 07, 2025 - 10:31 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Jan 06, 2025 - 08:11 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Dec 26, 2024 - 08:56 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Dec 19, 2024 - 10:46 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Dec 16, 2024 - 11:16 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Dec 09, 2024 - 11:08 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Dec 04, 2024 - 09:46 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Nov 25, 2024 - 15:33 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Nov 20, 2024 - 10:55 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Nov 13, 2024 - 09:29 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Nov 07, 2024 - 13:44 EST
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Nov 01, 2024 - 09:53 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolutioncontinues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Oct 22, 2024 - 09:02 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Oct 07, 2024 - 09:44 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Oct 02, 2024 - 13:56 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Sep 24, 2024 - 09:17 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Sep 16, 2024 - 08:48 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Sep 09, 2024 - 09:03 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution
Posted Aug 28, 2024 - 11:50 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Aug 14, 2024 - 09:17 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jul 30, 2024 - 09:06 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jul 19, 2024 - 13:28 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jul 10, 2024 - 08:54 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jun 28, 2024 - 09:46 EDT
Update
AblePay Health (ABLPY) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Jun 25, 2024 - 08:20 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 25, 2024 - 08:20 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:
AblePay Health (ABLPY)
Posted Jun 17, 2024 - 10:19 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:
AblePay Health (ABLPY)
Posted Jun 13, 2024 - 10:51 EDT
Update
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:
AblePay Health (ABLPY)
Posted May 29, 2024 - 10:46 EDT
Investigating
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected: