Real-Time Eligibility Payer Outage
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 10:47 EST
Identified
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected:

Medicaid Mississippi (SKMS0) - Fully responding (RESOLVED)
Posted Nov 13, 2024 - 11:06 EST