Blue Cross Community Option/66005 (MCDIL), MedStar Family Choice (RP063), Medstar Family Choice DC (RP062) & Partnership Health Plan of California (PHP02) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 20, 2024 - 15:43 EST
Update
MedStar Family Choice (RP063) & Medstar Family Choice DC (RP062) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 13, 2024 - 10:27 EST
Update
Blue Cross Community Option/66005 (MCDIL), MedStar Family Choice (RP063), Medstar Family Choice DC (RP062) & Partnership Health Plan of California (PHP02) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Nov 07, 2024 - 14:17 EST
Identified
Waystar EDI has confirmed the following payers are not responding with usable data for eligibility checks. We are working with the payers to restore service as quickly as possible. List of payers affected:
Blue Cross Community Option/66005 (MCDIL) - Fully responding (RESOLVED) MedStar Family Choice (RP063) - Fully responding (RESOLVED) Medstar Family Choice DC (RP062) - Fully responding (RESOLVED) Partnership Health Plan of California (PHP02) - Fully responding (RESOLVED)