Gold Kidney Health Plan (A6865) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 03, 2025 - 08:20 EDT
Update
Gold Kidney Health Plan (A6865) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Apr 02, 2025 - 13:05 EDT
Update
Gold Kidney Health Plan (A6865) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 31, 2025 - 08:44 EDT
Update
Gold Kidney Health Plan (A6865) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 28, 2025 - 10:47 EDT
Update
Gold Kidney Health Plan (A6865) continues to experience issues responding with usable data and we are actively working with them towards a resolution.
Posted Mar 26, 2025 - 13:27 EDT
Identified
Waystar EDI has confirmed the following payer is not responding with usable data for eligibility checks. We are working with the payer to restore service as quickly as possible. Payer affected: